Mobile app - not possible to add new journeys

I started travelling today with the interrail mobile app. Although I managed to get it all up and running for the first two legs of the trip, I am having critical issues with the app right now.


The problem is that the rail planner does not work anymore: each time I select a departure or destination, the planner resets again so it is impossible to add a new leg to my trip. The FAQ states that it is also possible to add journeys manually, but this option seems to be missing in the app I have (version 19.0.0 om android 10). So in essence it is downright impossible to add any journeys to my pass and thus to get a valid ticket, so I cannot travel any further. How can this be fixed?

I also contacted the support via email, but they say they will only answer within 7 days, which I think is pretty long if you are stranded with an app that is not working.


Best answer by Nanja 27 August 2021, 10:16

View original

11 replies

Right so I found a workaround by selecting the timetable per train station and then select individual trains to add to the journey. So at least I can get some new valid tickets, which makes it all a little less urgent.


Still it would be nice if this would be fixed though, the whole point of travelling for me is to not spent hours staring at a phone that doesn't do what it should.

Userlevel 7
Badge +8

Hi, I am sorry to hear you are experiencing issues with adding journeys. I'm glad you've found a workaround, but it needs to work like it should so that you can easily add the journeys. Our Customer Support team received your message in good order and will come back to you this morning at the soonest possible time. 

Thanks, that's fast :) Then I will pick up the conversation there.

We are having the exact same issue.  We arrived today and are set to begin our first journey tomorrow and the app will NOT let us add journey or obtain a ticket!!!!  We spent 45 minutes with the SBB information desk at Zurich station and they could NOT figure it out either!  We need urgent help and the customer support says they can’t get back to us for 7 days.  What do we do?????

We tried Pieter’s workaround and that helped at least for today but overall this app is not working properly and yet, THERE IS NO ONE TO CONTACT IN REAL TIME.  So if we hadn’t seen Pieter’s workaround, our passes would be UTTERLY USELESS.  Eurail needs to fix this ASAP.  We tried deleting and reinstalling the app, making sure the app is latest version and all the other tricks.  But nothing worked.  It would NOT let us add a journey to obtain a ticket.  At least for today Pieter’s workaround got us tickets to our destination but this problem needs to be solved.  What a crap app.

Try the workaround of adding journeys all to a single trip.  However you’re better off with paper, the app stinks

I’m having this issue now as well. We’ve had this for a month and using it a lot, no problem, and now I’ve been trying for days to add journeys but can’t add them anymore for certain days. We’re supposed to leave tomorrow for a week of traveling, but I’m about to cancel because I can’t get the app to work. This is a major problem. I haven’t tried deleting the app, I have mine and my 2 kids passes connected to my phone. If I delete and reinstall, can I reload our half used pass without problem?

Userlevel 7
Badge +8

Hi Ben, I am sorry to hear that you are experiencing issues with the App. Please delete and reinstall the App. In the meantime, can you please submit your Pass issues here. Once done, do let me know here or via a private message so that one of our Customer Support agents can look into it with you right away and get it sorted. 

Thank you! I have submitted a request and I will delete and reinstall my app. 

I had the very same problem (Google Pixel 2, Android 11) and found not only a workaround but what caused the issue for me.

In the developer settings of my phone, I had “Do not keep activities” turned on.
I deactivated that option, everything worked fine again.
( note that developer settings can only be accessed after activating them explicitly)

I suspect that if the manufacturer of a phone has strict battery saving measurements, that it could have the same effect, so it might help to turn of battery optimization for the app or check if any measures are active and deactivate them.

Userlevel 7
Badge +9

@Blabliblub Out of interest, I activated developer mode on my phone (Fairphone 3, Android 11) and then turned on "Do not keep activities”. That indeed prevents me from using the planner. I can choose a start station but that is wiped after choosing a destination (and the reverse).

@Nanja this seems to be a useful addition to the KB page "Basics to run the app”:

When using developer mode, the option "Do not keep activities” must be disabled.