Pass disappeared from DiscoverEu app

  • 19 August 2022
  • 5 replies


I need help urgently, because I’m leaving for my trip in 2 days!

My pass has randomly disappeared form the DiscoverEu app, and the my pass panel has also gone. I tried to add my pass in the Rail Planner app, but it says that I had already activated it and I can’t add it. 

 I’ve contacted the Customer Service and sent a request today.


Thank you for your help, it’s really urgent, I’m leaving on monday!


Best answer by rvdborgt 20 August 2022, 23:18

View original

5 replies

Userlevel 7
Badge +9
  1. What is your app version? See More, scroll to the bottom. If it is lower than 25.0.0, then update.
  2. If that doesn't work, then only customer service can help you. They can disconnect the pass, so you can activate it again. You need to give them your pass number and you need to tell them that you start to travel on Monday 22nd. It doesn't help to use "urgent” or "ASAP”, they need a concrete date to prioritise correctly.

Thank you, yes the app is updated. I sent them a request with the date, I hope they can fix it in time.

Userlevel 7
Badge +9

I corrected the app version (25.0.0 was released a few days ago).

Customer support also works during the weekend for urgent cases.


So I got an e-mail, and they de-registered me, so I could re-register on my phone. I redownloaded the Rail Planner app, logged in, added my pass. But it said that I’m using the wrong app, and since I’m a discover Eu traveller, I should download the DiscvoerEu app. (which I used before and which is now broken) So I downloaded that too, signed in and it was as bad as before. I attach a picture, there is no my pass panel, and when there was, there was no add pass button. My pass must be good, because the Rail Planner app sensed it, the problem is with my discover eu app. I tried everything with it, the add pass button, or even the my pass panel won’t appear.


pretty bad now


Userlevel 7
Badge +9

I must say I have no experience with the Discover EU app but it should have many of the same functions as the Rail Planner app.

Try the following:

  1. Turn off battery saving, data saving, airplane mode.
  2. Check the basics to run the app:
  3. Delete the app's cache and the stored app data and try again.
  4. Restart your phone and try again.
  5. Reinstall the app and try again (or did you try that already?)
  6. Do you have an iPhone or Android? Which version of the operating system?
  7. If nothing helps, go to More > Settings, scroll to the bottom and enable error logging. That won't solve the problem but will help customer service.
  8. Add all details, such as the latest screenshot, to your support request.
  9. Also send your device ID to customer service: