Can't access the self-service reservation tool

Hello! I am getting ready for a 2 month Eurail trip and I cannot seem to book my reservations for my first country, Norway. This could all be my own error but I would really appreciate any guidance someone may have!

I have a first class 2 month mobile global pass and my journeys for Norway show up in the Rail Planner as reservations required. Every time I open the “Book reservations” page on the Eurail site after logging in though, I do not see any timetable for me to book.

I added the 3 journeys I need for Norway onto my trip in the Rail Planner app and connected my pass (didn’t activate yet) and I still cannot see anything once I follow the steps in-app to get to the reservation self-service. Even when I log into my account on the site and go to “My trips and travelers”, the site shows me a blank page which I assume means that they have not even recognized that I created a trip on the app and connected my pass. I have been getting really confused and would appreciate any sort of help, would anyone be able to guide me in the right direction towards booking? Thank you so much!!


Best answer by amadeu 2 March 2022, 18:35

View original

12 replies

Userlevel 7
Badge +9

Something seems to be wrong as of today. “My trips and travellers” indeed shows an empty list and "Book reservations” does not show the form anymore to fill in departure, destination, date and time.

@Nanja, has something gone wrong?

@rvdborgt Thanks for the heads up! I will keep an eye out for any updates to the site over the next couple of days.

Userlevel 7
Badge +8

Hi Samyuktha and rvdborgt, there is indeed an issue on our side. It is reported just now, so we are working on a fix. I will let you know once resolved. 

Userlevel 1

@Samyuktha Chandrasekar The tool seems to work again as of now.

Userlevel 7
Badge +8

Hi, that's correct indeed. It has been resolved as of yesterday afternoon, @Samyuktha Chandrasekar


@Nanja Sorry to bother you, but I can’t seem to access it still. I just tried entering the website again and searching for the tools but the pages are the same as yesterday. The “My trips and travelers” is still blank and I don’t see the self-service tool either. I logged in to my Eurail account on Chrome, Firefox, and Safari too but nothing changed. Is there any way to fix this?

Userlevel 7
Badge +8

Hi Samyuktha, I'm sorry to hear that. I have redirected your comment to our Customer Support team to investigate. They will get back to you via email. In the meantime, can you also try to clear your cache and/or use the incognito browser and try again? This might resolve it. 

Thank you so much! I tried incognito already and it didn’t work :( Same with clearing cache. Hopefully this can get resolved soon as I want to book reservations as soon as I can.

Userlevel 7
Badge +9

I see you would like to book Norwegian trains.

For Norway you can also contact Entur, the organisation that handles ticket sales on behalf of Norwegian operators. Check this page (scroll down to Norway). Eurail will send Norwegian reservations by post (with extra postage costs on top of their 2 EUR extra fee per seat), whereas Entur can send them via email.

Thank you so much! I will use the page you linked to explore my options for the rest of my journeys as well. I am new to this so I appreciate the help tremendously :)

Userlevel 7
Badge +8

Hi Samyuktha, I see the issue has been resolved on Friday morning. If you experience issues again, do let us know. Have a great week ahead! 

I seem to be having the same problem with my account after logging in on the interrail website. I really need to make some seat reservations for the tgv in France as soon as possible!

Is there anything I can do to access the reservation service ??


thank you for your help and time!