Solved

is there a way to force my app to update itself

  • 16 September 2023
  • 15 replies
  • 163 views

Userlevel 2
Badge

Please help 

 

I have an issue finding trains in Slovenia. I have contacted the zendesk support but I wanted to ask this here too.

I have been told that my app is not up to date. I am on 34.1.0 but am told there is a newer version with the timetables in Slovenia working.

I have been to Google Play but I get this:

 

I can't find a way to force my rail app to update itself.

I had automatic updates turned on so I'm not sure what is going on.

icon

Best answer by Yorkie 19 September 2023, 14:56

View original

15 replies

Userlevel 7
Badge +4

I don’t know much about Android, but I guess you can always delete and redownload the app.

If you just want to check timetables, then bahn.com/en or https://potniski.sz.si/en/ will have the most up-to-date timetables.

Userlevel 2
Badge

I don’t know much about Android, but I guess you can always delete and redownload the app.

If you just want to check timetables, then bahn.com/en or https://potniski.sz.si/en/ will have the most up-to-date timetables.

Thanks. I'm wary of doing that whilst still on my trip. I'm doing everything on phones, whilst I prefer PCs. Don't want any chance of messing my ticket up. 😁

 

I spoke to a helpful lady in the station yesterday and she said "of course you can use Slovenian trains". I think she wondered why I was told I couldn't by another lady. I'd spoke to her about a train to Koper or Postojna cave.

In the end I booked a cheap coach to Koper. I think it's quicker than the train too.

It's only Slovenian trains causing me an issue ATM and I leave here in 2 days.

 

Still weird that it won't update. I tried it on another phone with Rail Planner on and that only updated to 34.1.0 too.

Two support on zendesk have told me there is a new update.

I may have to contact Google and see if they can help.

 

Thanks for the reply, @ralderton

Userlevel 7
Badge +4

If you ever can’t find a train in the planner, you can add it manually. (This is shown on the results page after you’ve searched.)

As long as your pass is valid for that day, it will be accepted by the guard. 

Userlevel 7
Badge +8

My Android is on 34.2.0.

Userlevel 7
Badge +8

You can always look for the app in Google Play and force the update manually. 

Userlevel 2
Badge

You can always look for the app in Google Play and force the update manually. 

I tried to do that but could not find an option.

Tried both through app management and going to the app itself.

Like I say, it's very strange.

Userlevel 2
Badge

This is what I see on the app page. Even my Google Play only knows about 34.1.0.

 

And Play Store is up to date.

 

Userlevel 7
Badge +8

What version does the Railplanner say that you have? Mine says 34.2.0 even though Google Play says 34.1.0 just like yours. Look at the bottom of the setting-page.

 

Userlevel 2
Badge

What version does the Railplanner say that you have? Mine says 34.2.0 even though Google Play says 34.1.0 just like yours. Look at the bottom of the setting-page.

 

34.1.0

 

Userlevel 7
Badge +8

If you look at the Railplanner-app in Google Play, does it say Update or Open, mine says Öppna=Open. If there is an update available it would say Uppdatera=Update.

Have you tried to uninstall and reinstall the app?

 

Userlevel 2
Badge

If you look at the Railplanner-app in Google Play, does it say Update or Open, mine says Öppna=Open. If there is an update available it would say Uppdatera=Update.

Have you tried to uninstall and reinstall the app?

 

It says open.

 

I have just tried a number of suggestions from clearing the cache and storage of Google Play to removing and adding my Google account.

It forced Play to find some updates for apps, but not Rail Planner.

I'm reluctant to reinstall whilst halfway through my interrail. I don't want the risk of messing up my ticket or trips.

It's currently only Slovenian timetables I can't find. I leave for Hungary on Wednesday and have already checked that Hungarian trains show.

I will contact Google at some point.

Google Play just does not see a 34.2.0 update on my phone. It doesn't see it on my old phone either.

 

As a last test, I installed the Rail Planner on my tablet. It shows version number 34.1.0.

 

It's as if 34.2.0 is not available on my Google. Maybe it is something to do with my mobile provider. The fact I'm using an E-Sim?

I'm really puzzled.

At least I have options to add trains manually. I shall maybe just have to sit patiently and wait for Google to see an update for Rail Planner.

34.1.0 only updated 1st September.

Userlevel 7
Badge +8

@rvdborgt Do you have any idea how to solve this?

Userlevel 2
Badge

@rvdborgt Do you have any idea how to solve this?

I have just contacted Google support, well last night actually. I got an answer but it didn't help. I have replied with a lot more details and included a number of screenshots.

I am wondering if it is a location thing. All three of the devices, that don't see update 34.2.0 are UK devices. I don't know enough about android or mobile devices to know if that would even be a thing.

Of course, my device has updated Rail Planner once since I've been away. I left home mid August and it update to 34.1.0 on 1st September.

I have to go now. I have a coach journey planned and need to get ready. Hopefully Google can solve this.

It is just really odd.

 

Thanks for all ideas, @AnnaB 😁

Userlevel 7
Badge +10

Just updated to 35.0.0 from Google Store

Userlevel 2
Badge

Just updated to 35.0.0 from Google Store

Good news, everybody.

 

I saw this post and checked Google Play.

 

I am now successfully updated to 35.0.0. I can see Slovenian trains. I have no idea what was up with 34.2.0 though.

 

Here's a pretty shot of Koper.

 

Thank you, @Yorkie

Reply