Cant access store on

  • 29 August 2021
  • 3 replies

I don’t know if it’s because I’m using an iPhone 7 with iOS 13.3.1 but I’d like to buy a new pass but I can’t access the store. My current pass has expired and I’d like to purchase a new 10 days in 2 months pass (I’m 31 years old so not the youth or senior citizens pass) but the links on the eurail website always take me to the same page. Even when I try and access the store via the Facebook shopping link it takes me to the same page. For reference the page I’m referring to just states at the top that there is a sale going on and has all of the general marketing info (conditions flexibility etc) but no specific links for specific passes. I’d like to travel tomorrow so I’d like to purchase this pass ASAP. Btw this problem has been ongoing for the past month or so every time I’ve tried to do this


Best answer by Felipe.iturrieta 1 September 2021, 10:30

View original

3 replies


That is the page I’m taken to. I’ve even tried different browsers (google chrome and safari) and tried requesting the desktop version

Userlevel 3
Badge +1

Hello Michael. I am very sorry to learn of this issue. It has been forwarded to our IT team. Did you manage to buy in the end? The page in the screen shot is indeed the one where you can buy the Passes - somehow the table with the prices is not showing for you. Normally, using an incognito window or different web browser helps, but as you mentioned, that did not work for you. Can you try using a different device or a PC?